cancel
Showing results for 
Search instead for 
Did you mean: 
stravers
Canine II

Version 8 Update

Can someone remind me where to go to print of the hardware and software requirements that are needed to install version 8?

Thanks in advance!

0 Kudos
Reply
1 Reply
Moderator
Moderator

Re: Version 8 Update

Sarah,

   Here is the link to our current system requirements page:

http://www.carestreamdental.com/us/en/support/SupportInfo#DocumentationSmiley Very Happyocumentation:1

0 Kudos
Reply