Showing results for 
Search instead for 
Did you mean: 

Address Finder Expiry Notification

We are aware that some Customers are receiving the below message from R4+


This error indicates that you are on version 8.1.3 or earlier and need to be on the latest version. 

You should have received correspondence via email and/or letter to give you details of your online portal ( to download the new version (Our current version release is 8.1.5). You will need your 'SAP Reference' which appears on correspondence from Carestream and your post code. 

If this is not the case or you need assistance please call 0330 094 8194.


Canine III

I downloaded the 8.1.5 upgrade today.

I backed up the database and endeavored to install the upgrade.

However, I got the following error message :

This machine is not the designated CSR4+ server, please run this update on the Server machine to continue.

However, I am definitely on the CSR4 server !

This happened previously in December 2020 when I upgraded to 8.1.3 and the helpline had to tweek a setting to enable me to effect the upgrade.

Next week is half term and exceptionally busy and given that all users have to log off  to effect this upgrade, I am at a loss to know when I might be able to so as all our appointment books are chock a bock.

Clearly, these upgrades need to be done outside surgery hours.

Can you let me know what I need to do to overcome this recurring error message ?

Is there a permanent fix or will a fix be needed at every upgrade ?

My designated CSR4+ server is a virtual Server running under Windows Hyper V and I wonder if that is the problem even though Carestream assured me that many sites ran CSR4+ on virtual Servers.

These upgrades really need to be run outside surgery hours.

Many Thanks,







0 Kudos

Morning Ed,

Many thanks for your post.

The error message you received is due to running the upgrade via an RDP connection, when you access the server PC via RDP it messes up the registry and doesn't believe it is the server PC.

Do you have an alternate way of accessing your server PC?



Thank you Matt,

Yes you are right, I was endeavouring to do this via RDP from my surgery.

However, today, after everyone logged out, I went onto our Server, backed up the database and tried again, but got the same message appeared.

This machine is not the designated CSR4+ server, please run this update on the Server machine to continue.

I am running R4 on a Virtual Server. After logging onto the physical server, I connected to the R4 server via Microsoft Hyper V. I presume R4 is treating this as the same way it does an RDP connection.

My Server specialist recommended running R4 on a Virtual Server because at the time R4 was not tested on Server 2019 and so I am running Server 2016 on this Virtual Server specifically for R4 whereas I am running Server 2019 for my other programs.

I did check with Carestream beforehand and I was told that lots of R4 Users are using Virtual servers successfully. However, it does seem to be causing this issue with updates.

How do I get around this ?

Many Thanks.

0 Kudos

Hi @edbyrne,

The issue would be that the registry has changed, there is a section in this that states "Is Server" this just needs to be amended.

If you could private message me your account number I will reach out and get this amended on the server PC.



0 Kudos

Good morning again Matt,

The helpline kindly edited the registry and the update to 8.1.5 went ahead later on that evening.

However, our Denplan data exchange link has not been working since last year.

We have telephoned the helpline several times.

I have now been told that it will work again if I upgrade to the latest Version 8.1.6

I have this upgrade on my server desktop but the error message has returned.

This machine is not the designated CSR4+ server, please run this update on the Server machine to continue.

This is an ongoing issue every time I try to upgrade. I can only deduce that the editing of the registry is temporary.

(i) Is it possible to make this registry alteration permanent ? Why does it keep reverting ?

(ii) Is it possible to alter R4+ upgrades to allow for virtual servers ?

We have been paying monthly for this Denplan data exchange which as I said has not worked for quite some time. It is very frustrating that I am dependant on the help line to facilitate an upgrade which has to be done outside normal working hours unless I am happy to close down a five surgery practice.

Would it be possible to e-mail me the precise instructions to edit the registry to allow the upgrade to run ?

I am not an IT professional but I am reasonably experienced and I understand the importance of Windows Regsitry.

I am confident that I can back it up, edit the line that needs editing, and then proceed.

It would be helpful to have details of the exact pathway to find the correct entry though.

Many Thanks,

Edward Byrne




0 Kudos

Hi @edbyrne,

Apologies for the issue that v8.1.5 regarding your denplan.

The error isn't due to it being a virtual server it is due to how you access the server PC, if you use the RDP service to access this is what knocks out the registry. I am unable to make a permanent change if this is the only way you can access the server.

Please can you private message me your eMail address and I will send over instructions on what to do, alternatively I can arrange a phone to complete if easier.

Kind Regards


0 Kudos