Showing results for 
Search instead for 
Did you mean: 
Canine III

Most Urgent : NHS Fee Update

Ian Pye said previously :

"There will be two separate items:-

  • The Fee update - which is mandatory and needs to be installed by the 14th December.
  • CS R4+ 8.1.3 - which allows transmission of triage information currently sent via compass, this is not mandatory and does not need to be installed prior to installing the fee update.

You will receive a letter and an email with your login details for the new update portal shortly."

I logged on this evening to download the fee update ready to install this Sunday.

(I am working flat out, Saturday included!)

I found three updates :

  1. NHS Fee update
  2. R4+ vers 8.1.3
  3. SQL EXpress 2014 upgrade.

The release notes said that YOU MUST BE RUNNING AT LEAST R4+ v 8.1.0 BEFORE INSTALL!

I am still on R4+ v 6.5.0 and SQL Server 2008 R2

So, as I see it this evening, I have to :

  1. Update SQL Server
  2. Install R4+ vers 8.1.3
  3. Then and only then can I update the NHS fees !

This is not something that I am at all comfortable doing on a Sunday in case anything goes wrong.

A fee update is one thing, but messing about with SQLServer is quite another.

If I had been given any advance notice of this I would have booked time off in the diary so as not to be faced with this alone on a Sunday.

Is there no way to simply update our fees ?



0 Kudos
CS Dental Employee
CS Dental Employee


We have previously released this information earlier in the year and again during the summer.

I can get someone to contact you tomorrow to manually update the fees, but would recommend updating as soon as you can. We work Saturdays and are currently open until 7pm.

Kind regards

0 Kudos

Good evening Ian,

I have no knowledge of any letter or e-mail informing me that the next NHS fee increase would require this SQL and / or R4+ update. If I knew, I would have updated R4+ in advance of the NHS fee implementation date, and probably allowed a little time in the diary.

Coming up to Christmas, we are still trying to catch up with a backlog of outstanding work from Coronavirus !

I spoke with Danny on Friday lunchtime but apparently it was not possible to update the NHS fees manually without first implementing the SQL Server 2014 update and then the R4+ V8.1.3

I was working yesterday with appointments but also on call for emergencies and it was 5.00 before I was able to address this.

So, I loaded the SQL express  Server 2014 before I left and left the other two for to-day.

However I kept on getting an error message that V 8.1.3. upgrade must be  done on the R4 Server even though I was on the R4  Server !



I tried running it as administrator but to no avail.

I wondered if it was too big a jump to go from 6.5.0 to 8.1.3 and so I tried upgrading to the latest disc in my possession which was 7.0.2

It threw up error messages when run from disc.


I tried running it as administrator, but the same error messages appeared.

I copied the disc to the desktop and ran it from there and it went through OK, the database updated and R4 was operational.

So, I then retried Vers 8.1.3 and it  also went through this time.

The database updated and R4+ was operational.

Great, or so I thought.

When I tried to update the NHS fees, I get the same initial error message as V 8.1.3 : it must be run from the R4 Server even though I am definitely on the R4 server !

When I went to update each workstation, R4+ updater goes through but R4 will not open.

I used R4+ updater with scroll lock to ensure it was connecting with the right server, but alas, R4 will not open on any workstation.



Given that R4+ is working on the Server, I am hoping that someone will be able to connect each of our workstations to the Server  and so I did not restore backwards to our original configuration.  I have made a copy of the Full Backup onto the Server Desktop just in case, as I presume Asynch Backup will run again this evening.

I am hoping that it is still possible to go forwards and get this running tomorrow, but, it has been very stressful.

I will try contacting the helpdesk first thing in the morning.

0 Kudos

I came home this evening hoping to resolve this with Carestream support first thing tomorrow morning.

My friendly Server advisor has just contacted me too make sure all went well.

He is great and makes himself available 24/7

He advised switching off Windows Firewall on the R4+ Server.

I logged in VPN and did this.

We leave two workstations switched on for remote access.

I logged onto the first  VPN and lo and behold, R4 loaded successfully.

I logged onto the second and it too loaded successfully.

I will get in early in the morning to do all the other workstations.

Next question, do I leave Windows firewall on or off ?

At least, I am cautiously optimistic about the morning.




0 Kudos

I just thought, before I go in early in the morning to connect all workstations to the server, it would be a good idea to update the NHS fees on the server which was our one and only goal in the first instance.

Alas, another error message, so after a weekend and many hours of attempts, nothing gained !






0 Kudos
CS Dental Employee
CS Dental Employee

Hi Ed,

Sorry to hear you have had these upgrading issues, it is a big jump from R4 6.x to 8.1.3

When running the updates make sure you are not connected via RDP.

If the update to 8.1.3 is working then the fees would have been installed with this.

In relation to the firewall, it should be on, but you will need to add an exception for Microsoft SQL server. The team can help with this.

We will be busy today, send me a personal message if you need any further help.

Kind regards