cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
mjpd
Canine II

Error message: This version not compatible with current data

Starting to get the following error message more frequently when I try to login to softdent on a machine: This version not compatible with current data.. Then softdent will quit and after trying a few more times sometimes I am able to get in. Other times I restart the computer and then it works. Other times nothing works, I come back 30 minutes later, and it works. Running V17. Some machines windows 10, some machines windows 7 professional. How do I fix this?

0 Kudos
Reply
1 Reply
CS Dental Employee
CS Dental Employee

Re: Error message: This version not compatible with current data

Call into Softdent support and they will assist you resolve this issue. 866-435-7473