OrthoTrac: Version 14 - Error "Component 'PWOrthotracControlsXPBUILDONLY.dll' or one of its dependencies not correctly registered" When Opening Charting

Document created by prcarter Employee on Apr 23, 2018
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Issue:

After the update to version 14.0.0.25, attempting to open Charting on a workstation produces the following error message:

 

Run-time error '339':

Component 'PWOrthotracControlsXPBUILDONLY.dll' or one of its dependencies not correctly registered: a file is missing or invalid."

 

(NOTE: This error message is misleading. The actual problem file is named "PWOrthotracControls.dll".

Cause:

Corrupted or problem installation of the Microsoft Windows component program Microsoft Visual C++ 2015 Redistributable (x86)

 

Solution:

This issue is not actually caused by OrthoTrac or the update itself, but is a result of a corrupted or problem installation of a Microsoft Windows component which several OrthoTrac files require for dependencies. The issue usually occurs when the operating system on the computer has not been kept up to date with the latest updates.

 

To correct this issue, please try the following in order:

 

1. Go to the Start menu and "cmd" to bring up a command window, then execute the following commands.  The path on the second command will vary slightly depending on whether the PC is running a 32-bit or 64-bit operating system.

32-bit OS:

cd c:\windows\system32

regsvr32 C:\Windows\System32\PWOrthotracControls.dll

 

64-bit OS:

cd c:\windows\system32

regsvr32 C:\Windows\SYSWOW64\PWOrthotracControls.dll

 

If a "DLLRegisterServer Succeeded" message appears, the problem should be resolved and Charting can be launched with no error.  If the registration fails with an error message, proceed to the next step.

 

2. Run Windows Update on the PC in question (regardless of whether it is a server or workstation). If Windows Update finds no updates available, proceed to the next step.

 

If multiple Windows updates are found and the PC is a workstation, proceed with installing all updates and then reboot the computer, then proceed with the next step.

 

If multiple Windows updates are found and the PC is a server, do not proceed with the updates or rebooting the server. Please contact your practice's computer technician and coordinate the updates with them first, then after the updates are all installed, proceed with the next step.

 

3. Download the "vc_redist.x86" installer for the Microsoft Visual C++ 2015 redistributable file. The file can be found here:

https://www.microsoft.com/en-us/download/details.aspx?id=48145

 

When downloading, select the (x86) version of the file. This version should be used regardless of what operating system is in use on the PC and regardless of whether it is a 32-bit or 64-bit OS. The Orthotrac control file is a 32-bit file so the redist support file needs to be 32-bit as well.

 

4. Launch the "vc_redist.x86.exe" file that you downloaded.

 

5. If the program is not already installed, you will see a "Install" window. Click "Install" and let the program install completely. If the program is already installed, the program will show "Repair" instead. Select that option and let the program repair completely.

 

NOTE: If there are errors during this process, or the program fails to install or repair properly, your office technician will need to resolve the problem as it is outside the scope of Support. Again, this issue is not with Orthotrac itself, but with Microsoft Windows not installing a Microsoft support file properly. The Microsoft Visual C++ 2015 Redistributable (x86)  program must be installed properly in order to continue.

 

6. After the program installs (or repairs), Go to the Start menu and type "cmd" to bring up a command window, then execute the following commands.  The path on the second command will vary slightly depending on whether the PC is running a 32-bit or 64-bit operating system.

32-bit OS:

cd c:\windows\system32

regsvr32 C:\Windows\System32\PWOrthotracControls.dll

 

64-bit OS:

cd c:\windows\system32

regsvr32 C:\Windows\SYSWOW64\PWOrthotracControls.dll

 

 

At that point a "DLLRegisterServer Succeeded" message should appear and the problem should be resolved.

 

 

 

[[Article ID:  20180223PRC1]]

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